Last Update: "2007/05/13 23:29:21 makoto"
build.sh
19 8:33 cvs update -D20061003
21 8:55 zcat ../20061003.NetBSD-current.diff.bz2 | patch -s -p0
22 8:55 ./build.sh -m sandpoint -a powerpc tools
23 8:55 unlimit
24 8:55 sudo ./build.sh -m sandpoint -a powerpc tools
26 9:31 sudo echo test
27 9:31 sudo ./build.sh -m sandpoint -a powerpc -T /work/src/tooldir.NetBSD-3.1_RC3-powerpc release > & log-build-release
/work/src/sys/arch/sandpoint/sandpoint/disksubr.c: In function 'mbr_to_label':
/work/src/sys/arch/sandpoint/sandpoint/disksubr.c:243:
error: 'MBR_MAGIC_EB' undeclared (first use in this function)
error: (Each undeclared identifier is reported only once
error: for each function it appears in.)
上記問題については GENERIC を作ろうとしている時で、実は GENERIC は作って
欲しくない
src/etc/etc.sandpoint/Makefile.inc
を変更
ある日付(あるいは単に current) で失敗した時に、
- cvs update -D 日付 等で更新する
- patch を当てる
と、追加するものについては、二重になってしまう
(追加 patch は変更ではなく「追加」なので、更に追加する)。
そこで、次のようにして、上記 1 の前に、orig が付いているものは
何らかの変更があったものだから、消しておく。
それには次のようにする。
16 8:33 cd src
17 8:33 find . -name \*orig -size 0 | sed 's/.orig//' | awk '{print "rm -f ",$1 "*"}' | sh
その後で cvs update -C -dP -A ; patch とする
cvs update -D20061003
zcat ../20061003.NetBSD-current.diff.bz2 | patch -s -p0
zcat /e/u/j/distfiles/mdrootimg.20050908.diff.bz2 | patch -s -p0
(調整)
./build.sh -m sandpoint -a powerpc tools
sudo ./build.sh -m sandpoint -a powerpc -T /work/src/tooldir.NetBSD-3.1_RC3-powerpc release > & log-build-release
調整とは..
src/etc/etc.sandpoint/Makefile.inc
objdump -O binary netbsd-INSTALL netbsd-INSTALL.bin
結果:
dmesg (4.99.3)
きょうの問題:
Status: Command failed
Command: pax -X -O -r -w -pe / /targetroot
Hit enter to continue
--------------------------------------------------------------------------------
pax: Cannot link to /targetroot/bin/cat from /targetroot/usr/bin/gzcat (Cross-device link)
これって、確かに / と /usr では(普通は) 別 fs だから ln は出来ないはず。
何故そうしているかな ..
98 md_copy_filesystem (void)
99 {
100 if (target_already_root()) {
101 return 0;
102 }
103
104 /* Copy the instbin(s) to the disk */
105 if (run_program(RUN_DISPLAY | RUN_PROGRESS,
106 "pax -X -O -r -w -pe / %s", targetroot_mnt) != 0)
107 return 1;
16 partitions:
# size offset fstype [fsize bsize cpg/sgs]
a: 2048256 11566800 4.2BSD 1024 8192 0 # (Cyl. 11475 - 13506)
b: 2048256 13615056 swap # (Cyl. 13507 - 15538)
c: 310102695 11566800 unused 0 0 # (Cyl. 11475 - 319116*)
d: 321672960 0 unused 0 0 # (Cyl. 0 - 319119)
e: 9638937 63 Linux Ext2 0 0 # (Cyl. 0*- 9562*)
f: 1927800 9639000 Linux Ext2 0 0 # (Cyl. 9562*- 11474)
g: 6144768 15663312 4.2BSD 2048 16384 0 # (Cyl. 15539 - 21634)
h: 20480544 21808080 4.2BSD 2048 16384 0 # (Cyl. 21635 - 41952)
i: 279380871 42288624 4.2BSD 2048 16384 0 # (Cyl. 41953 - 319116*)
#
fdisk
# fdisk wd0
fdisk: Cannot determine the number of heads
Disk: /dev/rwd0d
NetBSD disklabel disk geometry:
cylinders: 319120, heads: 16, sectors/track: 63 (1008 sectors/cylinder)
total sectors: 321672960
BIOS disk geometry:
cylinders: 1023, heads: 255, sectors/track: 63 (16065 sectors/cylinder)
total sectors: 321672960
Partition table:
0: Linux native (sysid 131)
start 63, size 9638937 (4707 MB, Cyls 0-600)
1: Linux native (sysid 131)
start 9639000, size 1927800 (941 MB, Cyls 600-720)
2: NetBSD (sysid 169)
start 11566800, size 310102695 (151417 MB, Cyls 720-20023), Active
3: <UNUSED>
#
|